NetAnim: change documentation to Qt5 ns-3.27
authorJohn Abraham <john.abraham.in@gmail.com>
Mon, 09 Oct 2017 09:45:32 -0700
changeset 13111 68978885b6fc
parent 13110 cc0c023e3c43
child 13112 af9cef56f8c9
NetAnim: change documentation to Qt5
src/netanim/doc/animation.rst
--- a/src/netanim/doc/animation.rst	Fri Oct 06 08:01:15 2017 -0700
+++ b/src/netanim/doc/animation.rst	Mon Oct 09 09:45:32 2017 -0700
@@ -88,20 +88,20 @@
 ================
 Prerequisites
 ~~~~~~~~~~~~~
-Qt4 (4.8 and over) is required to build NetAnim. This can be obtained using the following ways:
+Qt5 (5.4 and over) is required to build NetAnim. This can be obtained using the following ways:
 
-For Debian/Ubuntu Linux distributions:
+For Ubuntu Linux distributions:
 
 .. sourcecode:: bash
 
-  $ apt-get install qt4-dev-tools
+  $ apt-get install qt5-default
 
 For Red Hat/Fedora based distribution:
 
 .. sourcecode:: bash
 
-  $ yum install qt4
-  $ yum install qt4-devel
+  $ yum install qt5
+  $ yum install qt5-devel
 
 For Mac/OSX, see http://qt.nokia.com/downloads/
 
@@ -114,11 +114,11 @@
 
   $ cd netanim
   $ make clean
-  $ qmake NetAnim.pro  (For MAC Users: qmake -spec macx-g++ NetAnim.pro)
+  $ qmake NetAnim.pro
   $ make
 
 
-Note: qmake could be "qmake-qt4" in some systems
+Note: qmake could be "qmake-qt5" in some systems
 
 This should create an executable named "NetAnim" in the same directory: