Mention wiki page with prerequisites in tutorial
authorCraig Dowell <craigdo@ee.washington.edu>
Thu, 22 Apr 2010 09:23:26 -0700
changeset 626787a6cccfb2b5
parent 6266 35e7d9d585be
child 6270 43ffdd643b6a
Mention wiki page with prerequisites in tutorial
doc/tutorial/getting-started.texi
     1.1 --- a/doc/tutorial/getting-started.texi	Thu Apr 22 14:26:58 2010 +0200
     1.2 +++ b/doc/tutorial/getting-started.texi	Thu Apr 22 09:23:26 2010 -0700
     1.3 @@ -29,6 +29,26 @@
     1.4  @node Downloading ns-3
     1.5  @section Downloading ns-3
     1.6  
     1.7 +@cindex Prerequisites
     1.8 +@cindex Dependencies
     1.9 +The @command{ns-3} system as a whole is a fairly complex system and has a
    1.10 +number of dependencies on other components.  Along with the systems you will
    1.11 +most likely deal with every day (the GNU toolchain, Mercurial, you programmer
    1.12 +editor) you will need to ensure that a number of additional libraries are
    1.13 +present on your system before proceeding.  @command{ns-3} provides a wiki
    1.14 +for your reading pleasure that includes pages with many useful hints and tips.
    1.15 +One such page is the ``Installation'' page,
    1.16 +@uref{http://www.nsnam.org/wiki/index.php/Installation}.
    1.17 +
    1.18 +The ``Prerequisites'' section of this wiki page explains which packages are 
    1.19 +required to support common @command{ns-3} options, and also provides the 
    1.20 +commands used to install them for common Linux variants.  Cygwin users will
    1.21 +have to use the Cygwin installer (if you are a Cygwin user, you used it to
    1.22 +install Cygwin). 
    1.23 +
    1.24 +You may want to take this opportunity to explore the @command{ns-3} wiki 
    1.25 +a bit since there really is a wealth of information there. 
    1.26 +
    1.27  @cindex Linux
    1.28  @cindex Cygwin
    1.29  @cindex GNU
    1.30 @@ -37,9 +57,10 @@
    1.31  @cindex Waf
    1.32  From this point forward, we are going to assume that the reader is working in
    1.33  Linux or a Linux emulation environment (Linux, Cygwin, etc.) and has the GNU
    1.34 -toolchain installed and verified.  We are also going to assume that you have
    1.35 -Mercurial and Waf installed and running on the target system as described in
    1.36 -the Getting Started section of the  @command{ns-3} web site: 
    1.37 +toolchain installed and verified along with the prerequisites mentioned 
    1.38 +above.  We are also going to assume that you have Mercurial and Waf installed
    1.39 +and running on the target system as described in the ``Getting Started'' section 
    1.40 +of the  @command{ns-3} web site: 
    1.41  @uref{http://www.nsnam.org/getting_started.html}.
    1.42  
    1.43  @cindex tarball